Вход | Регистрация

1С:Предприятие ::

Метки:

Как привязать что документ Расходная накладная оплачен банковской выпиской

Я
   ppppp
 
16.05.05 - 10:28
Всем доброе утро! Написал обработку которая выводит расходные накладные на ВременныйРасчет(1)Регистра...а как сделать  что бы он сверял есть ли проплата документом Банковская выписка , документ проводится по регистру Взаимрасчеты также как и Расходная накладная ....
 
  Рекламное место пустует
   ppppp
 
1 - 16.05.05 - 10:29
Собственно код:
//

///-----------------------------------------------

Процедура ПриОткрытии()
    ДатаНач=РабочаяДата();
    ДатаКон=РабочаяДата();
КонецПроцедуры

Процедура Сформировать()
    Запрос=СоздатьОбъект("Запрос");
    ТекстЗапроса=
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаНач по ДатаКон;
    |Контрагент = Регистр.Взаиморасчеты.Контрагент;
    |СуммаБаз = Регистр.Взаиморасчеты.СуммаБаз;
    |Сделка= Регистр.Взаиморасчеты.Сделка;
    |Оплата= Регистр.Взаиморасчеты.Оплата;
    |РазделУчета = Регистр.Взаиморасчеты.РазделУчета;
    |Док= Регистр.Взаиморасчеты.ТекущийДокумент;
    |Менеджер= Регистр.Взаиморасчеты.Менеджер;
    |Группировка Контрагент;
    |Группировка Док;
    |Функция СуммаНачОст = НачОст(СуммаБаз); 
    |Функция СуммаПриход = Приход(СуммаБаз); 
    |Функция СуммаРасход = Расход(СуммаБаз); 
    |Функция СуммаКонОст = КонОст(СуммаБаз);
   //    |Условие (Контрагент = ВыбКонтрагент);

    |//}}ЗАПРОС

    ;
    
    Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
        Сообщить("Запрос не выполнен");
        Возврат;
    КонецЕсли;
   //----

   //Если ВыбКонтрагент.Выбран()=0 Тогда

   //    Предупреждение("Не выбран менеджер!");

   //    Возврат;

   //КонецЕсли;

    
    
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
   // для итогов перед началом прохода по группировкам получаем

   // значения функций для всей выборки сразу

    Таб.ВывестиСекцию("Шапка");
    
    Пока Запрос.Группировка()=1 Цикл
        
        Контрагент=Запрос.Контрагент;
        Док=Запрос.Док;
        Включаем фильтр
        Если НЕ(Док.Вид()="РасходнаяНакладная") Тогда
            Продолжить;
        КонецЕсли;
        НачОст=Запрос.СуммаНачОст;
        ПечПрих=Запрос.СуммаПриход;
        ПечРасх=Запрос.СуммаРасход;
        КонОст=Запрос.СуммаКонОст;
        Оплата=Запрос.Оплата;
        Менеджер=Запрос.Менеджер;
        Сделка=Запрос.Сделка;
        ДатаСделки=Сделка.ДатаДок;
        ПрДата=Док.ДатаДок;
        ПрОпл=Док.ДатаОплаты;
        РазделУчета=Запрос.РазделУчета;
        
        Если  (СокрЛП(РазделУчета)="Нал") И (ПрДата=ПрОпл) Тогда   
            ПрЗн=  Перечисление.ПризнакОплаты.Оплачено;    
        ИначеЕсли (СокрЛП(РазделУчета)="Нал") И (ПрДата<ПрОпл) Тогда  
            ПрЗн=  Перечисление.ПризнакОплаты.ОплаченоСПросрочкой;    
        ИначеЕсли  (СокрЛП(РазделУчета)="Безнал") И (ПрДата=ПрОпл) Тогда  
            ПрЗн=  Перечисление.ПризнакОплаты.Оплачено;
        ИначеЕсли  (СокрЛП(РазделУчета)="Безнал") И (ПрОпл=ДатаСделки) Тогда      
            ПрЗн=  Перечисление.ПризнакОплаты.Оплачено;
        ИначеЕсли  (СокрЛП(РазделУчета)="Безнал") И (ПрОпл>ДатаСделки) Тогда      
            ПрЗн=  Перечисление.ПризнакОплаты.ОплаченоСПросрочкой; 
        ИначеЕсли  (СокрЛП(РазделУчета)="Безнал") И (ДатаСделки.Выбран()=0) Тогда      
            ПрЗн=  Перечисление.ПризнакОплаты.Просрочена; 


        КонецЕсли;
        Если Запрос.Контрагент.ЭтоГруппа()=1 Тогда
            Таб.ВывестиСекцию("Группа");
        Иначе
            Таб.ВывестиСекцию("Контрагент");
        КонецЕсли;
        
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
КонецПроцедуры
   ppppp
 
2 - 16.05.05 - 10:45
Неужели ни кто не сталкивался ?
   427
 
3 - 16.05.05 - 11:11
и что ты хочешь?

Объяснять тебе принципы построения такой связи?... Так их всего несколько...
   ppppp
 
4 - 16.05.05 - 11:20
(3) Если не сложно объясни плиз...
   427
 
5 - 16.05.05 - 12:56
пля... форум косячит.. второй раз нарирать лень...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует